Mac mini Leopard Netzwerk langsam

Hallo zusammen,

habe schonmal zum Netzwerk und SMB gepostet. Da dachte ich noch es waere mein Samba server.
Aber mittlerweile nach einigen Wochenende Tests bin ich mir fast sicher(99%), dass es der mini ist.

Hier das Problem:
Verbunden ueber ethernet direkt am router und Internet ist echt lahm. Ich kommen mit dem Activity Monitor nicht ueber 350kb/s. Nach einiger Suche im Internet scheine ich nicht der Einzige zu sein.
Hat hier vielleicht noch jemand eine Idee ?

Was ich schon probiert habe:

  1. Alle manuellen Einstellungen (fest IP, full duplex, usw.)
  2. DNS Server eingegeben
  3. sysctl.conf (einige Eintraege)

Hat leider alles nicht geholfen. Bin so langsam echt frustriert.

Was ist uebrigens die Einheit, die der activity monitor anzeigt ? kilobit oder kilobyte ?

Wie schnell sollte denn überhaupt das Netz sein? Was erwartest du für Werte, bzw. welche Konfig hast du denn?

Ich habe mich per wireless mit einem xp rechner eingeloggt und bin locker ueber 1400kb/s gekommen. Mit dem mini habe ich es wie gesagt nie ueber 350 geschafft. habe eine 3mbit leitung.

Ursache des ganzen problems war eigentlich, dass ich es nicht schaffe eine einfache dvd mit dem mini zu streamen. mit dem xp rechner geht es sogar per wireless ohne probleme.
habe nach und nach alle moeglichkeiten ausgeschlossen und nun den mini direkt per lan kabel am router. aber es ist immer noch alles extrem langsam.

also keine direkte zielvorgabe aber einiges schneller muss es sein. einen weiteren vergleichswert erhalte ich demnaechst. da testet ein bekannter seinen speed.

Mal ne ganz blöde Frage.
Der Mini ist per Lan-Kabel am Router, läuft er auch über Kabel?
Oder ist er immernoch per WLAN am Router?
Geht er immer über Kabel, wenn das Lan-Kabel angeschlossen ist?

ja ganz sicher ueber kabel. wlan ist aus.

Der Mini ist fest auf Fullduplex gestellt? Dann muss der Port am Router auch fest auf Full stehen.

Mirko

Habe alles ausprobiert.

sind die kb/s im apple activity monitor kilobit oder kilobyte ?

falls es kilobyte sind komme ich auf ca. 3mbit. das entspraeche meiner leitung. der bekannte hat mit der gleichen testseite 600kb/s-1.2mb/s bekommen. er hat einen schnelleren zugang.
das koennte die ursache sein.

werde versuchen mit mehr netzwerk traffic (internet,stream…) das nochmal in die hoehe zu treiben.
und den test mit meinem mini bei ihm wiederholen.
melde mich dann wieder.

Das sind Bytes.

Ich dachte Du hättest eine langsame Verbindung zu einem lokalen Samba?

Mirko

Ja, das auch. Internet und lokales Samba.

Beim Sambaserver schaffe ich es mit dem Apple DVD player nicht eine normale DVD 4.5GB zu streamen. Da kommt maximal 1 Bild pro Sekunde und 5.1 Ton alterniert (an,aus,an,aus…)
Mit VLC ist es auch nicht besser. Mit meinem XP Rechner ueber wireless ist es kein Problem.

Na dann packe doch mal Iperf auf den Samba-Server und teste den Speed zwischen Server und dem Mac.

Mirko

Danke fuer den Tipp. Cooles tool kannte ich vorher nicht. Also hier die mac daten.


Server listening on TCP port 5001
TCP window size: 256 KByte (default)


Client connecting to 192.168.1.9, TCP port 5001
TCP window size: 129 KByte (default)

4] local 192.168.1.8 port 49411 connected with 192.168.1.9 port 5001
ID] Interval Transfer Bandwidth
4] 0.0-60.1 sec 80.3 MBytes 11.2 Mbits/sec
4] local 192.168.1.8 port 5001 connected with 192.168.1.9 port 1035
ID] Interval Transfer Bandwidth
4] 0.0- 0.0 sec 0.00 Bytes 0.00 bits/sec

unter windows bekomme ich 18Mbit per wireless. TCP window size ist allerdings 8kbyte. poste das mal hinterher

Hier die Windows Daten:

Server listening on TCP port 5001
TCP window size: 8.00 KByte (default)


Client connecting to 192.168.1.9, TCP port 5001
TCP window size: 8.00 KByte (default)

[1884] local 192.168.1.12 port 1337 connected with 192.168.1.9 port 5001
ID] Interval Transfer Bandwidth
[1884] 0.0-60.1 sec 131 MBytes 18.3 Mbits/sec

Hier die Server Seite:

iperf -s


Server listening on TCP port 5001
TCP window size: 42.7 KByte (default)

6] local 192.168.1.9 port 5001 connected with 192.168.1.12 port 1337
6] 0.0-59.4 sec 977 KBytes 135 bits/sec

Kann die TCP windows size ein Problem sein ? Wie stelle ich die ein ?

[quote=„root“]

Der Mini ist fest auf Fullduplex gestellt? Dann muss der Port am Router auch fest auf Full stehen.

Mirko[/quote]

Ich möchte noch mal auf diese Sache zurück kommen.
Wenn der :mini: fest auf Full Duplex und 100 MBit steht, dann muss auch der Port am Switch so eingestellt sein.
Sollte dem nicht so sein (was ich vermute, da du ziemlich sicher keinen managebaren Switch hast), ist der :mini: nicht bereit die Geschwindigkeit beim Verbindungsaufbau zu verhandeln. In so einem Fall wird der Switch entweder auf 100 Half Duplex oder gar 10 Half Duplex zurück fallen, was dann genau zu grottenschlechter Performance führt.

Fuer diese Messungen stand er auf automatisch. Full-duplex hatte ich nur mal zwischendurch ausprobiert, aber das hat alles nichts gebracht.

Also alle Ethernet Einstellungen auf automatisch. Kann mir jemand was zu den Messungen mit iperf sagen ? Ich denke das ist eine heisse Spur, aber ich kann es noch nicht richtig interpretieren.

Normales Internet scheint also gut zu funktionieren. Habe den Speed auch nochmal mit wieistmeineip.de getestet und alles palletti. Bleibt also noch die Verbindung zum Server.

So ist etwas her, aber jetzt ist es geloest. Habe mir ein neues NAS geholt, dass AFP kann und einiges mehr an power hat. Also NFS und AFP gehen. Samba nicht. Ich bin mir jetzt 100%ig sicher, dass apple samba einfach nichts taugt. Der letzte Beweis war, dass ein Bekannter von mir mit einem Macbook vom Mini per AFP streamt und auch keine Probleme hat. Nachdem er auf Samba umgestellt hat, auch Mega Ruckeln bei DVDs. Also es liegt echt am Samba des Minis!

Werde das auch mal an Apple berichten. Das kann ja echt nicht sein. Bin schon ein wenig enttaeuscht. Vielleicht kann ich mein neues NAS ja Apple in Rechnung stellen

[quote=“ultra-net”]So ist etwas her, aber jetzt ist es geloest. Habe mir ein neues NAS geholt, dass AFP kann und einiges mehr an power hat. Also NFS und AFP gehen. Samba nicht. Ich bin mir jetzt 100%ig sicher, dass apple samba einfach nichts taugt. Der letzte Beweis war, dass ein Bekannter von mir mit einem Macbook vom Mini per AFP streamt und auch keine Probleme hat. Nachdem er auf Samba umgestellt hat, auch Mega Ruckeln bei DVDs. Also es liegt echt am Samba des Minis!

Werde das auch mal an Apple berichten. Das kann ja echt nicht sein. Bin schon ein wenig enttaeuscht. Vielleicht kann ich mein neues NAS ja Apple in Rechnung stellen[/quote]

Was für ein NAS hast du dir geholt?

Ich bin auch gerade am Samba verzweifeln :frowning:

Hi LittleTeddy,

sorry fuer die spaete Antwort. Habe mir den Thecus N2100 geholt. damit geht es gut. Ist zwar im Vergleich zum NSLU2 nicht ganz billig, aber dafuer spart man eine Menge Zeit beim konfigurieren.