Schreibzugriffe auf die interne Festplatte sind sehr langsam

Ich habe eine Standard-Hitachi-Festplatte in meinem Mac, habe diese also nicht selbst eingebaut. Ich habe meinen Mac auch niemals zuvor geöffnet.
Seit kurzem sind die Schreibzugriffe auf meinen Mac mini extrem langsam. Ich weiß nicht, woran es liegt.

Ich habe einen Xbench-Disk-Benchmark laufen lassen, mit folgenden haarsträubenden Resultaten:

http://img360.imageshack.us/img360/107/screenshot01kt1.gif

http://img373.imageshack.us/img373/9344/screenshot02jn7.gif

Lesezugriffe funktionieren tadellos, Schreibzugriffe liegen bei gerade mal ca. 3-4 MB pro Sekunde… das Acht- bis Elffache sollte aber die Regel sein (und war vorher ja auch die Regel), selbst wenn sich’s “nur” um eine Notebook-Festplatte handelt!

Kurz zusammengefasst:
a) Als ich den Xbench-Test laufen ließ, habe ich alle möglichen Programme beendet, welche auf die Festplatte zugreifen könnten: iTunes, Time Machine, EyeTV und dergleichen
b) Zugriffsrechte habe ich repariert, man weiß ja nie…
c) Den Status der HDD habe ich über das Festplatten-Dienstprogramm überprüft, der Status ist grün, alles in Ordnung

Woran könnte es liegen? Habt ihr Ähnliches erlebt oder Links parat (vielleicht sogar hier im Forum)? Ich kann meinen mini immer noch produktiv nutzen, das Schreibzugriff-Manko fällt kaum auf, aber der “Beachball” erscheint immer häufiger, wenn ich mal mehrere plattenintensive Dinge gleichzeitig mache (z.B. Podcast-Download in iTunes und gleichzeitiges Surfen auf YouTube oder komplexen Websites)… selbst die Festplatte des MacBook Air mit 4200 Umdrehungen pro Sekunde ist bei Schreibzugriffen potenter. Also: Wer weiß Rat? Habe gleich zwei Backups griffbereit, sollte die interne Platte also abrauchen, bin ich gewappnet.

Zwei Dinge fallen mir spontan ein:

  1. Hast du kürzlich einen Virenscanner installiert?
  2. Ist die Platte fast voll? (Habe gehört, dass bei sehr wenig Platz das Filesystem langsam wird)

[quote=“Jonny”]Zwei Dinge fallen mir spontan ein:

  1. Hast du kürzlich einen Virenscanner installiert?[/quote]

Nein, habe ich nicht. Ich habe letztens nur ein wenig Software deinstalliert (z.B. den Adobe Reader: vor einigen Monaten wusste ich wirklich noch nicht, dass OS X von Haus aus PDFs öffnen kann). Zudem habe ich die Microsoft Remotedesktopverbindung heruntergeladen, um mein Notebook bequem über meinen Mac mini zu steuern. Bitte keine Flames über das Microsoft-Programm, es erleichtert mir wirklich das Leben.
Ich glaube/hoffe nicht, dass die Deinstallation, bzw. Installation dieser Programme die Schreibzugriffe negativ beeinflusst hat. Letztens ist EyeTV 3.0.2 erschienen, aber auch das sollte keinen Einfluss auf die HDD-Geschwindigkeit haben.

[quote=“Jonny”]
2. Ist die Platte fast voll? (Habe gehört, dass bei sehr wenig Platz das Filesystem langsam wird)[/quote]

Im Gegenteil, habe eine 160GB-Platte, und rund 60GB sind immerzu frei… hätte ich das früher gewusst, wäre ich gleich beim 120GB-Modell geblieben. Aber besser zuviel Speicher als zu wenig. :wink:

Das verstehe ich jetzt aber nicht :kopkr:
Ist das die serienmäßig verbaute Platte und der :mini: war noch nie offen oder ist da nun eine andere Platte drin?

Ich meinte damit, dass mir auch das Standard-120GB-Modell des Mac mini gereicht hätte und ich nicht zwingend im Apple Shop die Option “160 GB HDD” hätte wählen müssen. Die 160GB-Platte ist in jedem Fall die serienmäßig verbaute. Tut aber in diesem Fall wohl nix zur Sache. Sorry für meine missverständliche Wortwahl. :blush:

Es scheint irgendwie an der Platte zu liegen, denn mein SuperDuper!-Backup auf 'ner Firewire-Platte ist schön schnell, nachdem ich es beim Bootvorgang ausgewählt habe. Meine interne Festplatte ist leider immer noch (zu) langsam bei den Schreibzugriffen. Mitunter merke ich’s kaum. Wenn noch jemand Rat weiß, bitte melden. Wenn sich das Problem irgendwie löst, werd ich auch nochmal darauf zurückkommen.

OK, jetzt hab ich es kapiert :bulb:

Hm, könnte sein, dass die Platte mit Bad Block Replacement beschäftigt ist. Will heißen, dass auf der Platte viele defekte Blöcke sind und er diese durch gute Reserveblöcke ersetzten muss, die natürlich wo anders liegen und viele Seeks die Performance bremsen (hm, sollte dann aber auch beim Lesen bremsen). Wenn das der Fall ist, dann mach fleißig Backup, die Platte stirbt bald. Schau doch mal in die Konsole, ob sich da Meldungen zu Schreibfehlern finden.
Hast du noch Garantie? Wenn ja, mach mal einen Call bei Apple auf oder wende dich an den Händler deines Vertrauens.

Glücklicherweise kann ich das falsifizieren, da ich durch einen riesigen Zufall der Lösung auf die Spur gekommen bin. Eins vorweg: Ich werde Apple auch im nächsten Jahrzehnt treu bleiben, aber manchmal packt mich doch das Grauen, auch wenn Apple selbst für den Fehler der langsamen Festplatte nicht verantwortlich ist. Letztlich sind Apple-Computer doch nur supersexy Windows-Systeme. Nur Spaß… :wink: Doch nun zur Sache!

Das Problem des langsamen Schreibzugriffs ist auf smcFanControl zurückzuführen. Ja, ganz recht, genau das Tool, was bei gefühlten 30% der Nutzer dieses Forums ohne jegliche Probleme in der Menüleiste läuft. Ich hab’s mir bei den steigenden sommerlichen Temperaturen also mal genauer angeschaut, mit dem Wissen im Hinterkopf, dass es unter Umständen die Lebensdauer des Lüfters einschränken könnte. Wie auch immer, ich hab’s also mal getestet und mir auch gleich ein paar Presets zurechtgelegt, das Minimum beträgt ja immer 2500 Umdrehungen pro Minute. Ich bin also in 400er-Schritten raufgegangen bis circa 4100 Umdrehungen pro Minute, um zu prüfen, wie laut der Lüfter des Mac mini röhrt und inwieweit die Temperatur des Prozessors und der Festplatte sinkt. Auch wenn ich es technisch nicht im Geringsten erklären kann: Bei exakt 3200 Lüfter-Umdrehungen pro Sekunde konnte die Festplatte nur noch etwa 2MB pro Sekunde schreiben! Bin ich mit den Lüfter-Umdrehungen auch nur um jeweils 100 nach oben oder unten gegangen, wurde dem Spuk ein Ende gesetzt. Jetzt habe auch ich „normale“ Xbench-Testergebnisse. Jedenfalls konnte (und kann) ich auch nach mehreren Rechtereparaturen, Neustarts und dergleichen das Verhalten reproduzieren: Immer bei 3200 Lüfter-Umdrehungen pro Sekunde „entscheidet“ sich die Festplatte, langsamer zu werden. Bei allen anderen möglichen Lüfterkonfigurationen taucht das nicht auf.

(Randnotiz: Wenn ich von meinem SuperDuper!-Backup starte und auch dort die Lüfter-Umdrehung auf 3200 stelle, taucht das Problem allerdings nicht auf, sondern nur, wenn ich von der internen Platte starte)

Vorläufiges Fazit: Ich will smcFanControl nicht verteufeln. Ich bin froh, dass alles wieder im Lot ist. Auf die 3200 Umdrehungen kann ich also verzichten. :wink:
Wenn ich dran denke, wie lange die Fehlereingrenzung potenziell hätte dauern können. Ich trage mir deshalb schon seit ein paar Monaten immer in iCal ein, wenn ich neue Software installiere und Updates einspiele. So kann ich immer zurückverfolgen, wann der Fehler erstmals auftrat und welche Software daran Schuld sein könnte.

Ah, bei 3200 UMin braucht der Lüfter vermutlich den meisten Strom und die Platte muss dafür langsamer drehen :crazy:

Nun mal Spaß beiseite, das soll einer verstehen wo da der Zusammenhang ist :8S:
Ich könnte es ok, dass das System insgesamt bei hoher Lüfterdrehzahl und hoher Temperatur gebremst wird, da der Lüfter dann offensichtlich die Wärme nicht weg bringt.

Das finde ich einen sehr guten Ansatz, dann erübrigen sich viele Kaffeesatz Lesereien.