Textedit Probleme

Hi@all,

ich habe seit ein paar Tagen Lion auf dem Mini und bin sehr zufrieden damit. Nur Texedit treibt mich schier in den Wahnsinn. Ich nutze den Editor u.A. um xml Dateien zu editieren (Plex Skin). Die xml Dateien lassen sich auch problemlos öffnen, aber beim speichern ändert mir Texedit den Suffix grundsätzlich in “.txt” um :blink:

Der Arbeitsablauf aus Ändern-Speichern-Testen erweitert sich dadurch um den Punkt “Dateisuffix manuell auf .xml ändern”, den ich nun immer zwischen Speichern und Testen einfügen muss. Auch der “Speichern unter” Menüpunkt scheint der Vergangenheit anzugehören. Die Textedit Einstellungen hab ich mir schon angeschaut, leider ohne Ergebnis.

Was übersehe ich hier? Hat jemand einen Tipp für mich?

lg

Michael

EDIT:
Ich habe jetzt mal Smultron installiert. Gefällt mir recht gut! Trotzdem würde mich interessieren ob ich Tomaten auf den Augen habe, oder ob Textedit wirklich nur noch stur .txt anhängt…?

Dummfrag: Die Checkbox „Dateisuffix ausblenden“ gibt es unter Lion nicht mehr?

Ansonsten verwende ich am liebsten TextWrangler.

1 „Gefällt mir“

Meinst Du im Finder? Dort gibt es die Oprion “Alle Dateinamensuffixe einblenden”. Ändert leider auch nichts.

Ich habe gerade noch eine Entdeckung gemacht. Es werden scheinbar nur bekannte Suffixe geändert. Erstelle ich eine Datei mit einem unbekannten Suffix, z.B. Test.fft, dann bleibt der Suffix beim erneuten Speichern erhalten. xml und rtf werden gnaden- und kommentarlos auf txt geändert.

Danke für den Tipp zu TextWrangler. Den schaue ich mir mal an.

lg

Michael

Bin gerade regelmässig zu spät. Ich wollte dir ebenfalls Textwrangler empfehlen. Gerade zum scripten einfach die bessere Wahl. :smile:

1 „Gefällt mir“

TextWrangler gefällt mir auch sehr gut. Die Darstellung ist viel übersichtlicher als im Textedit und alles funktioniert wie gewohnt.

Vielen Dank für die Tipps :smile:

lg

Michael

Nein, nicht im Finder. Wie gesagt: das sind keine Lion-Screenshots, da kann es durchaus sein, dass alles anders ist:



.
Ich habe Textedit Version 1.6 und da gibt es die “Suffix ausblenden” Checkbox nicht …

bei mir schaut das so aus: ->

Oha. Alles klar…

Kategorie: verschlimmbessert… :confused:

TextEdit in Lion hat Version 1.7 und sieht genauso aus wie es Jörg gepostet hat! Die Wirkung der Checkbox ist allerdings etwas seltsam, genau wie das Verhalten das die automatisch angewählt wird sobald man im Dateinamensfeld einen Punkt eingibt…

Warum die Dateiendung bestehender Dateien automatisch geändert wird, kann wohl nur Apple beantworten. :confused:

Ist innerhalb der IBM auch ein bekanntes Problem. Die Einstellungsdatei von Lotus Notes heißt ‘Notes Preferences’ und nach dem Editieren eben mit Dateiendung, was Notes so garnicht mag. :wink: Vielleicht wird das mal mit einem Update wieder geändert.

Hi,

ich habe mir jetzt Smultron und den Text Wrangler beide mal genauer angesehen. Bin bei Smultron hängen geblieben und sehr zufrieden damit :smile:

lg

Michael

Ich habe mir Kod 0.0.3 beta installiert, der hat solche Fehler nicht, hat aber außer Syntax highlighting noch nicht viele Funktionen eingebaut. Text-Wrangler hat scheinbar Probleme mit dem Zeilenumbruch, oder wurde der Fehler behoben? Bei dem was ich auf der Smulton Seite gelesen habe, kann man sich fast sicher sein für die 5er Version wieder neu zu bezahlen.

1 „Gefällt mir“

Supi - Kod sieht interessant aus.

Aber die Option unter “View - Text Display - Soft Wrap Text” hast du ausprobiert?

Nein, ich habe nur gelesen, dass er Probleme haben soll, eventuell ist es ja schon behoben. Ich schaue mir Text-Wrangler heute mal an.

In den Einstellungen bei Text-Wrangler sollte man den Haken bei “Textfiles”/“Translate line breaks” entfernen sonst ist die Gefahr gross sich Dateien zu vermurksen. Bei “Editor Defaults”/“Soft wrap Text” einschalten und auf “Window width” stellen, danach Text-Wrangler schließen damit die Einstellungen übernommen werden. Etwas komische default Einstellungen.

Wenn man viel mit einem Editor arbeitet, lohnt sich auch ein Blick auf BBedit10 hier für 40$
grüße Frank