Intel Mini 2006: Probleme mit SSD

Hallo!

Ich habe einen der ersten Intel Minis von 2006 mit einem Core Solo.

Um ihn weiter benutzen zu können, habe ich ihn jetzt etwas “frisiert”.
Zunächst habe ich den Prozessor gegen einen Core2Duo getauscht, was sehr gut ging.

Dann habe ich das Laufwerk gegen ein SSD Laufwerk ausgetauscht und habe nun das Problem, daß das Laufwerk nicht erkannt wird. Ich sehe dann das blinkende Fragezeichen.

Abhilfe bringt ein Pramreset, danach ist starten möglich. Aber leider nur, bis ich den Mini das nächste Malr runtergefahren habe.
Da ich den Rechner abends auschalte muss ich dann morgens Pramreset machen und kann dann erst starten.

Auch der Hibernatemodus Speicher auf die Festplatte geht nicht mehr, der Rechner findet die Platte nicht wieder.

Die Platte heisst SanDisk Ultra II 480GB

Habt Ihr eine Lösung hierfür?

Ich wäre für Tipps sehr dankbar.

Gruss, Harm.

Hallo Harm,

wie hast Du das OS X auf die SSD gespielt (vor allem, welche Version)? Ist unter Systemeinstellung -> Startvolume die SSD eingetragen? …und Du hast die SSD auch HFS+ formattiert?

Hallo!

Danke für Deine Antwort!

Die SSD hatte ich vorher mit dem Carbon Copy Cloner mit dem laufenden System bespielt. Version ist 10.6.8

Sie ist als Startvolumen eingetragen und HFS+ formatiert.

Seltsam ist ja, daß sie nach dem Pramreset erkannt wird und dann auch startet. Aber jedes Mal, wenn ich den Mini herunterfahre nicht mehr.

Gruss, Harm.

Oh, mit CCC kann es zu Problemen kommen:

a) Wenn die Festplatte und SSD nicht exakt den gleichen Namen tragen, kann es zu Problemen kommen - eigentlich sollten die nach eine PRAM/NVRAM Reset behoben sein. Nach so einen Eingriff sollte man sicherheitshalber auch des System Management Controller (SMC) resetten.
Siehe Apple Support:
NVRAM-Reset
SMC-Reset

Könnte die Pufferbatterie leer sein?

b) Es kann Aufgrund der Speicherverwaltung durch den SSD-Controller (der Mini hat bei einer SSD keinen direkten Zugriff mehr darauf) zu Problemen kommen - vor allem sollten alle Festplatten-Tools (Programme) überprüft werden. Wichtig ist z. B. Defragmentierprogramme abzuschalten. Wenn nach PRAM/NVRAM und SMC Reset das Problem immer noch besteht, würde ich mit dem Festplatten Dienstprogramm die Rechte reparieren.

Wenn das nichts hilft, würde ich das Mac OS X von der System DVD neu aufspielen und wenn das nichts bringt, die Pufferbatterie austauschen.

Hallo!

Ich habe die Pufferbatterie mal getauscht, SMC Reset mache ich ja immer, wenn ich ihn abends stromlos schalte.
Die Rechte sind auch repariert.

Jetzt bleibt nur noch, das System neu aufspielen, das verschiebe ich aber auf den Urlaub…

Was mir nicht in den Kopf will: Nach dem Pramreset startet das System ja. Also muss doch während der Laufzeit irgendwas abgespeichert werden, was ich dann mit dem Reset wieder lösche.
Aber was kann das sein?

Danke erstmal für Deine Tipps.

Gruß, Harm.

Der Mini ist ca. 10 Jahre alt. Eine Pufferbatterie hält ca. 3 bis 6 Jahre. Wird der Recher regelmäßig vom Stromnetz getrennt, dürfte diese stärker beansprucht werden. Also könnte die Batterie durchaus wieder leer sein.

Für mich klingt das fast so, als wäre ein Schreib- oder Lesebefehl auf eine feste Adresse auf die HDD gerichtet, die Aufgrung der Eigenverwaltung des Festspeichers durch den SSD-Controller nicht mehr dort liegt, wo sie liegen sollte. Beim PRAM Reset erkennt das Programm die geänderte Struktur, kann diesen Fehler aber nicht dauerhaft ändern, weil die Änderung an die falsche Speicheradresse geschickt wird. Also wiederholt sich dieses “Spiel” permannent. Das kann so etwas Banales wie irgend ein Mountpoint vom System oder ähnliches sein.

Daher meine Hoffnung, das mit Neuaufspielen des Systems das wieder “hingebogen” werden kann. Wahrscheinlich kann die alte Version von CCC nur ein HDD auf eine andere HDD sauber abbilden. Bei der anderen internen Struktur der SSD können so Fehler entstehen.

Die Pufferbatterie ist ja nun eine neue.

Wenn ich das Backupmedium (eine Firewireplatte) angehängt lasse, sehe ich kurz das Fragezeichen, dann aber wird die Firewireplatte erkannt und von dieser gestartet.

Ich werde also als nächstes versuchen, das System komplett neu aufzusetzen.
Wäre ja mal interessant zu sehen, ob das was bringt.

Ich werde berichten…

Gruss, Harm.

So, ich habe jetzt neu von CD installiert:

  1. nur überinstalliert.

  2. Vorher mit Festplattendienstprogramm die Zielplatte “gelöscht” und dann neu installiert.
    Allerdings habe ich im Zuge der Installation die Home Verzeichnisse vom Backup Medium migriert.

Was machen wir jetzt?

Gruss, Harm.

Soll das heißen, das Problem besteht weiter?

Ja, das ist alles unverändert.
Man gewöhnt sich dran vor jedem Start einmal alt-apfel-p-r zu drücken. Aber elegant ist das nicht. Irgendwas muss das System doch in den Speicher schreiben, das ich jedesmal löschen muss, oder?

Gruss, Harm.

Hmm, zu SSD Unterstützung von Mac OS X 10.6 ist kaum noch was zu erfahren - meißt landet man auf Seiten zu TRIM vs. Garbage Collection und wie man am Mac TRIM einschaltet (nach wie vor: TRIM enabler).

Ich vermute eher einen Fehler durch Carbon Copy Cloner. Da CCC Backups auf Blockebene macht, es aber bei SSDs keine festen Blockgrößen gibt (genauer gesagt, es gibt sie intern SSD-Controller schon, darauf hat man anders als bei Fesplatten keinen direkten Zugriff drauf) kommt wahrscheinlich irgend ein entscheidender Mountpoint an einer falschen Stelle an.

Zu diesem PRAM-Reset-Kreislauf kann es ja nur kommen, wenn es nicht gelingt den Mountpoint richtig zu „fixieren“, also die Start-Adresse dauerhaft richtig zu setzen.

Als einzige Möglichkeit sehe ich nur, nachdem das System „frisch“ aufgespielt und sämtliche Systemupdates eingespielt sind, die Inhalte nicht mit CCC herüberzuholen sondern entweder händisch, oder (falls es OS X intern funktionieren sollte), mit den Migrationsassistenen zu übernehmen. Wenn es das nicht ist, oder die Stützbatterie, ist bei mir ende mit Latein und ich habe auch in meinen üblichen Quellen nichts weiteres zu diesen Problem gefunden :nopla:

O.K. Kein Problem, ich kann das System ja nocheinmal von vorne aufsetzen. Allerdings hatte ich den Eindruck, daß das Problem schon wieder auftauchte, als ich den CCC noch gar nicht benutzt hatte. Ich hatte ja das System neu installiert und dann per CCC nur die Homeverzeichnisse kopiert.
Und die Stützbatterie ist ja schon neu.
Ich werde also nochmal ganz neu installieren und den Carbon Copy Cloner komplett umgehen.

Muss ich die Platte neu formatieren oder reicht “löschen” mit dem Festplattendienstprogramm?

Danke und Gruss! Harm.

Bist du sicher, dass es etwas mit der Platte zu tun, oder setzt irgendwas die EFI Eintraege zurueck ? was die Platte “ausblendet” ?
Unter Linux schau ich mir den Inhalt mittels “efivar -l” an, die Eintraege manipulieren tue ich mit efibootmgr unter linux:
smurphy@pandora:~$ efibootmgr
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0000,0001
Boot0000* rEFInd Boot Manager
Boot0001* ubuntu

Ich bin sicher es gibt sowas auch aufm Mac um sich mal die Eintraege anzuschauen.

Hallo smurphy.

Ich vermute auch eher, daß irgendwas die EFI Einträge zurücksetzt. Nur was?

Ich habe jetzt mal den Rechner mit einer CD gestartet auf der rEFIt gebrannt ist.
Dann bekommt man eine Shell. Allerdings verstehe ich da bisher nur Bahnhof, da braucht es wohl mehr Kenntnisse, als ich so habe.

Gruss, Harm.

Ah, das könnte uns dem Problem näher bringen. rEFIt wird nicht mehr gepflegt - es wurde durch eine neuere Entwicklung abgelöst (gerade nicht im Kopf, muß nochmal recherchieren). Das entscheidende ist aber, wenn Deine SSD eine andere Kapazität als die vorherige Festplatte hat, werden sämtliche Mountpoints zu den verschiedenen Partitionen falsch gesetzt und da Mac OS X diese nicht einfach selber setzten kann (sie liegen im EFI) dürfte es zu diesem Dauerfehler kommen.

Abhilfe könnte nur ein neues Aufsetzten und Partitionieren der SSD mit rEFIt oder ein anderen Bootloader der sich im EFI verankert bringen - das wäre dann ein verständliches Verhalten.

        	chrispiac mmf-genius               
  1. Februar
    Ah, das könnte uns dem Problem näher bringen. rEFIt wird nicht mehr gepflegt - es wurde durch eine neuere Entwicklung abgelöst (gerade nicht im Kopf, muß nochmal recherchieren). Das entscheidende ist aber, wenn Deine SSD eine andere Kapazität als die vorherige Festplatte hat, werden sämtliche Mountpoints zu den verschiedenen Partitionen falsch gesetzt und da Mac OS X diese nicht einfach selber setzten kann (sie liegen im EFI) dürfte es zu diesem Dauerfehler kommen.

Abhilfe könnte nur ein neues Aufsetzten und Partitionieren der SSD mit rEFIt oder ein anderen Bootloader der sich im EFI verankert bringen - das wäre dann ein verständliches Verhalten.

Visit Topic or reply to this email to respond

To stop receiving notifications for this particular topic, click here. To unsubscribe from these emails, change your user preferences

Hallo!

Ein Partitionstool habe ich gesehen. Also dann die SSD mit rEFIt neu partitionieren und dann das OSX neu installieren?
Danach müsste ich aber dann doch die home Verzeichnisse und alte Programme per CCC kopieren können, oder?

Wie müsste ich denn partitionieren, damit es funktioniert? Und: Macht das OSX beim neuinstallieren nicht sowieso wieder seine eigenen Partitionen, so wie es sie braucht?

Lauter Fragen…

Gruss, Harm.

Nun, normalerweise partitioniert man vor dem aufspielen und Partitionen können ja auch abgeändert werden (zumindest machen z. B. aktuelle Windowse, aus DOS [=Fat32] ein NTFS Laufwerk das müsste eigentlich auch ins EFI eingetragen werden). Das Problem ist, das wenn Du mit CCC ein vollständiges Backup über alle Partitionen erstellt hast (inkl. EFI) und die Kapazität von der ursprünglichen Festplatte zur SSD abweicht, CCC die Partitionen skalliert, das EFI aber die Mountpoints beibehält (so wie sie ins EFI geschrieben wurden). Das heißt, erst mit FDP die SSD partitionieren, dann rEFIft oder anderen EFI Bootloader aufspielen, ggf. Partitionen anpassen und dann Inhalte von der alten Festplatte auf die SSD überspielen (das sollte nach der Einrichtung CCC können nur bitte EFI herausnehmen - sofern Du es findest, sonst bleibt Dir zur Sicherheit nur das händische überspielen.

        	chrispiac mmf-genius               
  1. Februar
    Nun, normalerweise partitioniert man vor dem aufspielen und Partitionen können ja auch abgeändert werden (zumindest machen z. B. aktuelle Windowse, aus DOS [=Fat32] ein NTFS Laufwerk das müsste eigentlich auch ins EFI eingetragen werden). Das Problem ist, das wenn Du mit CCC ein vollständiges Backup über alle Partitionen erstellt hast (inkl. EFI) und die Kapazität von der ursprünglichen Festplatte zur SSD abweicht, CCC die Partitionen skalliert, das EFI aber die Mountpoints beibehält (so wie sie ins EFI geschrieben wurden). Das heißt, erst mit FDP die SSD partitionieren, dann rEFIft oder anderen EFI Bootloader aufspielen, ggf. Partitionen anpassen und dann Inhalte von der alten Festplatte auf die SSD überspielen (das sollte nach der Einrichtung CCC können nur bitte EFI herausnehmen - sofern Du es findest, sonst bleibt Dir zur Sicherheit nur das händische überspielen.

Hallo!

Ich habe ja gar nicht alle Partitionen per CCC kopiert, sondern auf der Platte erst eine Partition erstellt mit dem FDP, und dann per CCC die Daten aufgespielt.
Wurden dabei dann vielleicht die EFI Partition mit kopiert? Gesehen habe ich sie nicht…

Beim zweiten Mal habe ich erst per FDP die Platte gelöscht, dann neu per Installationscd installiert, dann per CCC nur die Homeverzeichnisse und die fehlenden Programme rüberkopiert. Insofern wundert mich immer noch etwas, wie es zu dem Problem kommt.

Vielleicht wurde die alte Partition mit “falschen” EFI bei der ersten CCC Aktion mit kopiert und dann nie wieder geändert?

Ich werde diese Partition mal (mittels rEFIt) entfernen und dann neu anfangen. Das könnte klappen, oder?

Danke an Euch für Eure Bemühungen!

Harm.

jep - das müßte gehen. Normalerweise sieht man den EFI-Teil auch nicht. Nur wenn man ihn explizit aufruft wie @smurphy es gezeigt hat, bekommt man ihn angezeigt. CCC und TimeMachine sind aber nur auf Mac OS X ausgelegt. Wie diese Programme mit alternativen Bootloadern umgehen, kann ich nicht abschätzen. Bootloader wie rEFIt müssen dort aber Mountpoints und die Partitionstabelle im MBR ablegen. Werden diese nicht dem neuen Medium (SSD) angepasst, kann es zu Schwierigkeiten kommen.

Daher halte ich es für wahrscheinlich, das nach dem Partitionieren und neu Installieren der /des alternativen Bootloaders/-Managers die geschilderten Probleme nicht mehr auftreten.

Daher halte ich es für wahrscheinlich, das nach dem Partitionieren und neu Installieren der /des alternativen Bootloaders/-Managers die geschilderten Probleme nicht mehr auftreten.

Zumindestens habe ich mal wieder eine Menge gelernt.

Ich werde also mal so vorgehen und dann berichten.

Harm.