OS X 10.6: kann nicht von DVD booten zum installieren

Hallo,

ich habe schon in Eurem und anderen Foren kreuz und quer gelesen, gegoogelt
und bin immer noch zu keiner Lösung gekommen.

Ich möchte auf meinem MacMini (Core2Duo 1,83 1G RAM) Snow Leopard installieren. Nur klappt das einfach nicht.

Hier mal kurz der Ablauf, was ich schon alles probiert habe:

  1. DVD geladen, vom Desktop aus gestartet; Auswahl getätigt; alles läuft los, bis zu dem Punkt, an dem neu gebootet wird. Danach kommt nur noch der “Wartebildschirm” und nichts geht weiter.

  2. neu gebootet per Power off/on: OS X 10.5 startet wieder

  3. NVRAM zurückgesetzt; neuer Versuch wie 1. ; gleiches Ergebnis

  4. neu gebootet und versucht, von der Snow Leopard DVD zu booten: bleibt wieder bei “Wartebildschirm” stehen

  5. von 10.5 (Original-System) DVD gebootet; Intensiv-Test durchgeführt (RAM…)
    alles OK

  6. wieder in 10.5 gebootet; TimeMachine gestartet; Backup-Volume entfernt

  7. von 10.5 DVD gebootet; Festplatte platt gemacht; DVD ausgeworfen

  8. Versuch von 10.6 DVD zu booten: bleibt wieder hängen

  9. 10.5 DVD wieder rein, System wiederhergestellt mit TimeMachine-Backup-
    nach ca. 1h alles wieder da (bis auf manche Mail-Postfächer…)

  10. 10.6 DVD rein, Neustart mit DVD-Booten, aber im verbose-mode
    den Screenshot dazu hänge ich mal an. Kann jemand daraus irgend welche
    Probleme erkennen?
    (Meine Vermutung: die fehlenden ‘boot-args’; sind womöglich mal flöten gegangen, als ich schon mal den NVRAM zurückgesetzt hatte; will aber nichts daran ändern, solange ich mir nicht sicher bin)

Habe ich noch eine Chance vor Weihnachten :santa: ?

ok,

da es seit über einer woche nicht weitergeht, gehen wir die sache mal in etappen an.

wenn ich meinen nvram auslese im terminal (nvram boot-args) bekomme ich folgendes:

nvram boot-args
nvram: Error (-1) getting variable - 'boot-args'

wie sehen bei euch die variablen aus, gibt es bei euch einen eintrag bei den boot-args?

viele gruesse
micha

.
hast du es schonmal mit einer anderen DVD 10.6 versucht? die scheint 'hin zu sein …

die Konsole kann ich nicht auslesen, davon hab’ ich keine Ahnung :cofus:

Hallo Micha,

1.) handelt es sich bei Deiner SnowLeo-DVD zufällig um eine, die mit einem neueren Mini (oder anderen Mac) geliefert wurde? (Damit ist booten auf einem älteren Mac Mini nicht möglich)

2.) ich hatte mal ähnliche Probleme mit einer Upgrade DVD von 10.4 auf 10.5 gehabt. Damals half es, das ich das Startvolume bei eingelegter Upgrade DVD in den Systemeinstellungen manuell ausgewählt hatte (Also: Systemeinstellungen -> Startvolume -> die DVD auswählen und ggf. Passwort eingeben!) Scheinbar konnte das Startvolume nicht ohne Passwort geändert werden, was die Startreihenfolge dann total durcheinander brachte (bei einem anderen Rechner gab es Probleme mit der Medienerkennung, ein externes DVD-Laufwerk brachte dort Abhilfe).

Mehr fällt mir dazu aber auch nicht ein. Viel Erfolg!

Hallo,

@ kosuan: DVD habe ich schon umgetauscht, die neuere ging genauso wenig, aber auslesen in ein image (festplatten-dienstprogramm) geht ohne probleme->keine leseprobleme

@chrispiac:

  1. nein, neu im MediaMarkt gekauft
  2. das mit dem startvolume hab ich auch probiert

wenn man es genau betrachtet: booten geht ja im prinzip, aber immer nur bis zum “wartebildschirm”, der endlos ist, und wenn man im verbose-mode bootet, sieht man die stelle, bis wohin er kommt (siehe bild am ersten posting)

konsole: programme->dienstprogramme->terminal
dort kann man auch die man page von nvram nachlesen (man nvram) bzw. eben bestimmte variablen auslesen
(nvram boot-args zum beispiel)

aus den letzen meldungen auf dem screenshot werde ich nicht schlau, für mich sieht das so aus, das er
ein problem mit dem fehlenden boot-arg hat, deshalb waere mal interessant, ob da bei euch was drinsteht :8?:

Starten mit gedrückter “C” Taste schon probiert?

Und falls dann immer noch Fehlermeldungen kommen: Die mitgelieferte DVD mit AHT (Apple Hardware Test - steht klein auf dem Rand einer der grauen mitgelieferten System DVDs) mit gedrückter “D”-Taste im Laufwerk starten, dann sollte mit ein wenig Glück ggf. ein Hardware-Fehler gefunden werden.

Andernfalls könnte die SnowLeoDVD hin sein oder Du hast im EFI rumgepatched (Linux drauf? Oder ein anderen Bootloader wie Refit?)

-Start mit gedrückter “C” Taste geht, aber endet wie gesagt am “wartebildschirm”
-Start vom desktop aus geht, man kann seine Einstellungen machen, er fängt an Systemdateien zu kopieren, dann bootet er -> und kommt nicht weiter

AHT (Version 3A152) von der mitgelieferten DVD gemacht, alles OK, auch Speicher mehrmals intensiv getestet

-EFI nicht gepatched (kein Linux, kein anderer Bootloader, auch kein Bootcamp ->nehme Parallels)

.
Eine Möglichkeit wäre vlt. noch, wenn du einen 2ten Mac hast - den Mini im TargetModus zu starten, per Firewire (vlt. geht auch USB) mit dem andern zu verbinden und dort die DVD einzulegen.
Als Zielvolumen dann deinen Mini auswählen und darauf installieren.

Das Firmware-Upgrade für die DVD-Laufwerke wurde installiert?
Ansonsten würde ich den Umtauschen.

@kosuan
zweiten Mac hab ich leider nicht - also fällt das flach…

@Michael B
Firmware-Upgrade fürs DVD-Laufwerk - das musst du ein wenig näher erläuern - kann man das irgendwo runterziehen?
Mein Mini ist schon über ein Jahr alt - September 2008 (1.83 DualCore 1G RAM)

generell:
Das Booten startet ja an sich, bleibt nur dann ein wenig später “stecken” siehe Screenshot (wenn man den im posting anklickt, kann man auch alles
soweit lesen). Da ist auch erkennbar, das er FireWire/Bluetooth/Ethernetadapter etc. erkennt, das er ein paar RAM-Disks anlegt, und dann kommt er ins stocken…
entweder, weil iregndwas nur read-only ist (habe aber auch schon meine Platte platt gemacht -siehe erstes posting - ging auch nicht), oder vielleicht, weil er
boot-args nicht finden kann und daher die “64-bit bootcache list” nutzt -die dann vielleicht iregndwo falsch hin zeigt.

Daher wäre vielleicht ein Vergleich sinnvoll, ob bei euch diese Variable gesetzt ist - und welchen wert sie hat, bei mir ist sie ja vielleicht durch
einen NVRAM-Reset verloren gegangen?

Hmmm…
dass mit dem 64-Bit Boot list sagt mir dass da was nicht stimmt,
Installiere nocheinmal 10.5 und geh ins Terminal und geb ein: ioreg -l -p IODeviceTree ⎮ grep firmware-abi
So wenn du die Antwort : <“EFI32”/
bekommst weiß ich, glaub ich, woran es liegt wenn : <“EFI64”/
ist bin ich ratlos!
Mfg Xiider
Quelle Macwelt

Habe wieder 10.5.8 laufen, und wenn ich “ioreg…” im Terminal eingebe, kommt eine ellenlange Ausgabe,
und den (hoffentlich interessanten) Teil hab ich mal rauskopiert:

[code]
±o efi <class IOService, !registered, !matched, active, busy 0, retain 7>
| | {
| | “firmware-revision” = <01000010>
| | “device-properties” = <d50700000100000003000000c60600001600000002010c$
| | “name” = <“efi”>
| | “firmware-vendor” = <4100700070006c0065000000>
| | “firmware-abi” = <“EFI32”>
| | }
/code]

ist es jetzt erkennbar, woran es liegt?

ich denke schon,
Die Dvd versucht im 64 bit Modus zu starten, dein Mac kann aber kein 64 bit.Ich glaube daher gibt es Probleme mit der 64-bit bootcache list. Bin mir aber nicht sicher. Versuch mal während dem Starten 3 und 2 auf dem Ziffernblock zu halten, ich bin mir da nicht so sicher, aber um im 64 bit Modus zu starten muss man 6 und 4 drücken.
Mfg Xiider

Wenn es aber wirklich ein Core2Duo ist, dann ist der 64bit fähig. (es sei denn der ist irgendwie selbst aufgerüstet o.Ä.)

Die Installer-DVD hat eine Text.datei wo alle (Hardware-)Voraussetzungen genannt werden. Da könnte sich ein Blick lohnen.

Vor einiger Zeit gab es ein EFI-Update: support.apple.com/kb/DL888

Allerdings habe ich von dem Handling des Updates keine Ahnung, war bei meinem glücklicherweise nicht nötig.

Vielleicht hilfts. LG

Hallo,

bin eben erst zum probieren gekommen, Feiertagsstress…

Also wenn ich das EFI-Update installieren will, kommt:

“Warnung Dieser Computer benötigt dieses Update nicht.” Also hab ich das abgebrochen.

Wenn ich den Mini starte und 3 2 drücke, verläuft er sich genauso wie beschrieben, es geht also nicht weiter.
Funktioniert das mit dem 32 oder 64 drücken nicht erst beim neuen Kernel (den ich ja indirekt mit SL installieren will)???

@Xiider: Kannst Du im Terminal mal auslesen, ob bei dir diese “boot-args” Variable gesetzt ist?

@ BitsandBytes
Nein das EFI32 heißt, dass er kein 64-bit unterstützt, Ende!

Bei mir kommt:

[quote]Last login: Mon Dec 28 12:47:00 on console
macbook-marius:~ mari$ nvram boot-args
nvram: Error getting variable - ‘boot-args’: (iokit/common) data was not found
macbook-marius:~ mari$ [/quote]

Das sollte so aber auch sein

[quote]The nvram command allows manipulation of Open Firmware
NVRAM variables. It can be used to get or set a variable.
It can also be used to print all of the variables or set a
list of variables from a file.
[/quote]

Mac hat keine Open Firmware oder?

Mal eine dumme Frage, wie willst Du das installieren, wenn Du nicht mal mit einem Account angemeldet bist? Hab ich eine Wissenslücke?

[quote=“Michael B”]

Mal eine dumme Frage, wie willst Du das installieren, wenn Du nicht mal mit einem Account angemeldet bist? Hab ich eine Wissenslücke?[/quote]

Welcher Acc? Irgendwie komm ich nicht mehr mit :confused:

Versuch´s mal mit Apfel+3+2!
Mfg Xiider

Apfel (also cmd) +3+2 geht leider auch nicht :imp: